Loading...

Follow MongoDB | Reddit on Feedspot

Continue with Google
Continue with Facebook
or

Valid

In this tutorial I will show you how to create a MongoDB cluster in the cloud with MongoDB Atlas. http://on.geeklearn.net/3e7b7f8b57

submitted by /u/JJohnson0x
[visit reddit] [comments]
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 

not sure if this is the right place but I'm looking to increment update an array in pymongo. Most examples i've seen have a static increment value, however, I would like for it to increment by the value in another array in the same location, such as:

'array1.$[i]': array2[i]

anyone know how to do this? Thanks

submitted by /u/bdog1097
[visit reddit] [comments]
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 

Is anyone interested in participating in a weekly challenge to win some cash/prizes?

If you know MongoDB and want to demonstrate your skills - check out this week's challenge:

https://mdbwchallengeweek4.splashthat.com/

You can leverage a free MongoDB Atlas account to participate - just follow the instructions and submit your entry in the form on that page.

submitted by /u/merlynn22
[visit reddit] [comments]
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 
MongoDB | Reddit by /u/oczekkk - 1d ago
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 
MongoDB | Reddit by /u/egocentryczny - 2d ago

Hello!

I'm creating a Rest API service using Express and MongoDB. I have a collection for each user, but each document uses the same schema.

How can I set my collection dynamicly (ex. using req.params.{collectionName})?

submitted by /u/egocentryczny
[visit reddit] [comments]
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 

Hi everyone,

I can download and install MonoDB Enterprise Server from mongo download center, so it just charge money when I need support from Mongo? All the features of this free download Enterprise version is similar with the version MongoDB Enterprise Advanced ?

submitted by /u/Stryker88888
[visit reddit] [comments]
Read Full Article
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 

Whenever I try to connect using the mongo shell and I specify more than 3 hosts in the --host argument, I get an invalid url error. Is this expected behavior? I can't find any information regarding this limit.

Example:

[testuser@mongotest10 ~]$ mongo --host "mongotest10,mongotest11,mongotest4,mongotest5,mongotest6" --quiet --eval "rs.status()" 2019-05-21T13:00:10.111-0400 E QUERY [thread1] Error: invalid url [mongotest10,mongotest11,mongotest4,mongotest5,mongotests:27017] : connect@src/mongo/shell/mongo.js:231:14 @(connect):1:21 

but when i knock the list down to 3 i get this

[testuser@mongotest10 ~]$ mongo --host "mongotest4,mongotest5,mongotest6" --quiet --eval "rs.status()" 2019-05-21T12:54:23.291-0400 I NETWORK [thread1] SyncClusterConnection connecting to [mongotest4:27017] 2019-05-21T12:54:23.324-0400 I NETWORK [thread1] SyncClusterConnection connecting to [mongotest5:27017] 2019-05-21T12:54:23.356-0400 I NETWORK [thread1] SyncClusterConnection connecting to [mongotest6:27017] { "ok" : 0, "errmsg" : "not authorized on admin to execute command { replSetGetStatus: 1.0 }", "code" : 13 } 

Which is what I'd expect (because I didn't auth, I don't care about that part).

It seems as though after 3 hosts it messes up the connection and then it starts treating the whole list as a single server (noted because it appends :27017 to the end of the whole list instead of the end of each host). I tried appending :27017 to the end of each host and got the same error (except each host had 27017 at the end but the entire list was in a single set of square brackets still)

Any help with this is appreciated.

edit - The behavior is not consistent. I am able to replicate the behavior on a few of our linux machines and a windows workstation but I am unable to replicate the behavior on my local vagrant environment and another dev cannot replicate it on his windows machine. I am unsure as to what is causing this and why it's inconsistently behaving across machines.

edit 2 - I think this is a problem with v3.2. I am not able to reproduce this in v4.0. I haven't tried other versions.

submitted by /u/zylo4747
[visit reddit] [comments]
Read Full Article

Read for later

Articles marked as Favorite are saved for later viewing.
close
  • Show original
  • .
  • Share
  • .
  • Favorite
  • .
  • Email
  • .
  • Add Tags 

Separate tags by commas
To access this feature, please upgrade your account.
Start your free month
Free Preview