UEFI cannot detect dualboot of arch on it's own /boot partition
Arch Linux Forums
by EugeneForce
51m ago
I've installed arch linux alongside windows. Both OSes work fine and i can switch between them by intercepting the boot and choosing between 'WIndows Boot Manager'  for windows and 'Efi Hard  Drive' for Linux. However, when i want to adjust the boot order to boot arch first, i can't find Arch or any indication of arch in the BIOS menu. All i can see within OS Boot manager entry in WIndows boot manager. I guess this has something to do with how i installed arch. I have an EFI partiton for windows on /dev/sda1. And i have my boot partition for arch on /dev/sda6 (boot). How can i config ..read more
Visit website
Multiple keyboard layouts in KDE/Wayland
Arch Linux Forums
by Salkay
2h ago
I have a laptop with a "normal" keyboard layout. I normally swap caps and control. I also have an external keyboard that I use half the time. This is an ergonomic keyboard, with the control in a sensible place. Hence, I don't want anything swapped when using the external keyboard. With X11, I used /etc/X11/xorg.conf.d to provide keyboard-specific layouts. e.g. the external keyboard had Option "XKbOptions" "lv3:ralt_switch_multikey,numpad:pc" whereas internal keyboard had Option "XKbOptions" "lv3:ralt_switch_multikey,numpad:pc,ctrl:swapcaps" Is there a way to do this under Wayland? I ..read more
Visit website
New dialog on KDE "Authentication is required to suspend this system"
Arch Linux Forums
by brachiosnorus
2h ago
Recently I've started seeing a dialog when I resume my computer from suspend. It doesn't show up every time that I resume and I haven't observed any patter as to when it appears and when it doesn't. I'm using latest Plasma and the dialog says: "authentication is required to suspend this system" with a prompt to enter my password. The details state: Action: Suspend the system ID: org.freedesktop.login1.suspend Vendor: The Systemd project My user is part of the following groups: sys adm wheel Suspend works without providing a password. If I do provide it (after resuming), I can see the follow ..read more
Visit website
Having zram enabled drastically lowers games fps when charging.
Arch Linux Forums
by earthian
5h ago
How I've setup zram: - installed zram-generator from arch repos - echo `[zram0]` into `/etc/systemd/zram-generator.conf` - reloaded the `systemd-zram-setup@zram0` - created `/etc/sysctl.d/99-vm-zram-parameters.conf` file with following contents: vm.swappiness = 180 # increase percentage to start using zram earlier vm.watermark_boost_factor = 0 vm.watermark_scale_factor = 125 vm.page-cluster = 0 vm.oom_kill_allocating_task = 1 - rebooted After all that zram works like a charm. On my laptop with ~15G ram i really feel better having zram UNLESS 2 conditions are met: laptop is charging and ther ..read more
Visit website
Problem creating PKGBUILD for Node app (files exist in filesystem)
Arch Linux Forums
by gromit
12h ago
See https://gitlab.archlinux.org/archlinux/ … -/issues/2 ..read more
Visit website
.exe doesnt work if i dont use the command "killall wineserver"
Arch Linux Forums
by carlosmatheusneto
12h ago
I am new to linux, using it for about 1 year, and i am having a big problem. I normally dont install .exe files because i know wine isnt a emulator, but a bridge that may work or may not work. The problem i am facing is : i have a .exe file to install, and after i install it creates an app on my computer. Both app, .exe install file, and the .exe for unistall file doenst work unless i command killall wineserver on console. I have no idea what error is this, i normally dont install .exe files, but in this case i need because there's nothing in pacman/AUR for this app. After the command it works ..read more
Visit website
[b]Error installing Python modules on Arch Linux [/b]
Arch Linux Forums
by jiolocus
12h ago
Hello everybody, I'm experiencing an issue when trying to install Python modules using pip on my Arch Linux system. When I run "pip install --break-system-packages <module> | that happen for all modules "  I get the following error: Defaulting to user installation because normal site-packages is not writeable ERROR: Exception: Traceback (most recent call last): File "/usr/lib/python3.12/site-packages/pip/_internal/cli/base_command.py", line 179, in exc_logging_wrapper status = run_func(*args) ^^^^^^^^^^^^^^^ File "/usr/lib/python3.12/site-packages/pip/_internal/cli/req_command.py ..read more
Visit website
PHP HTTP extension is incompatible, and I can't install PECL/PEAR
Arch Linux Forums
by SomeoneNoone
13h ago
I'm trying to get a working PHP installation, but none of the supported php versions seem to have a working http module, which is a dependency of my project. So far I've tried installing php-http & php-raphf, as well as some attempts to get PECL/PEAR installed which didn't pan out. When running `php -v` with php-http and raphf instaleld, I get: > php -v PHP Warning: PHP Startup: Unable to load dynamic library 'http.so' (tried: /usr/lib/php/modules/http.so (/usr/lib/php/modules/http.so: undefined symbol: php_resource_factory_handle_dtor), /usr/lib/php/modules/http.so.so (/usr/lib/php ..read more
Visit website
Build failed while linking. How to continue without rebuilding ?
Arch Linux Forums
by vesse
13h ago
$ makepkg ... [ 96%] Linking CXX shared library ../../lib/libQt5WebKit.so collect2: fatal error: ld terminated with signal 9 [Killed] compilation terminated. make[2]: *** [Source/WebKit/CMakeFiles/WebKit.dir/build.make:2034: lib/libQt5WebKit.so.5.212.0] Error 1 make[2]: *** Deleting file 'lib/libQt5WebKit.so.5.212.0' make[1]: *** [CMakeFiles/Makefile2:1839: Source/WebKit/CMakeFiles/WebKit.dir/all] Error 2 make: *** [Makefile:166: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... PKGBUILD Setting: 8GB of RAM, approx. 4GB available 8GB of swap Build directory ..read more
Visit website
[solved] New arch install-internal audio not working.
Arch Linux Forums
by notaflyingcat
15h ago
I have no idea why it works, I'm just posting this to avoid being the dreaded "nvm I figured it out" guy that people cuss out  months later. I installed and uninstalled the alsa, restarting after installation and uninstallation. Now it works. I wish I knew why. Have a nice day, to whoever reads this. I hope it works eventually for you as well ..read more
Visit website

Follow Arch Linux Forums on FeedSpot

Continue with Google
Continue with Apple
OR