IBM-AIX Blog
6 FOLLOWERS
The IBM-AIX Blog is an official blog by IBM dedicated to sharing updates, announcements, and technical information about IBM AIX. The blog helps readers to stay informed about the latest advancements in AIX, gain insights from IBM experts, and discover resources to help them maximize the value of AIX in their organizations.
IBM-AIX Blog
1y ago
Migrating HACMP to PowerHA 6.1 in aix?
Migrating HACMP version 5.4 or lower to PowerHA 6.1 using Snapshot
GROUND WORK:
#lslpp -l|grep -i cluster.es --> To check the current version of the cluster
#./clRGinfo --> Check if the RG is online status.
#lssrc -ls clstrmgrES --> check if the cluster manager is stable on bot ..read more
IBM-AIX Blog
1y ago
How to remove the hard disk (pdisk) in aix?
The below steps are clearly explained how to remove the hard disk (pdisk) in aix.
Please follow the below steps to replace the hdisk (pdisk) with the following steps
$ oem_setup_env
smitty sasdam
=> Delete a SAS Disk Array
=> sissasO
=>hdisk4
Confirm that we want to delete the array, you should get a message stating something like
hdisk4 deleted
pdisk4 Defined
ESCĂ·O or F10 (this may change according to your keyboard) to exit smitty
# diag
=> enter
=> Task Selection (Diagnostics, Advanced Diagnostics, Service Aids, etc.)
= Hot Plug ..read more
IBM-AIX Blog
1y ago
#!/bin/bash
# Get hostname
HOSTNAME=$(hostname)
echo -e "\033[32mHostname: $HOSTNAME\033[0m"
# Get operating system version
OS_VERSION=$(cat /etc/redhat-release)
echo -e "\033[32mOperating system version: $OS_VERSION\033[0m"
# Get kernel version
KERNEL_VERSION=$(uname -r)
echo -e "\033[32mKernel version: $KERNEL_VERSION\033[0m"
# Get uptime
UPTIME=$(uptime -V | sed 's/up //')
echo -e "\033[32mUptime: $UPTIME\033[0m"
# Get last reboot date
REBOOT_DATE=$(last reboot | head -n 1 | awk '{print $4, $5, $6, $7, $8, $9}')
echo -e "\033[32mLast reboot date: $REBOOT_DATE\033[0m"
# Get total ..read more
IBM-AIX Blog
1y ago
Very useful command related to network concept in aix?
How to identify the default gateway in aix?
#netstat -nr|egrep -iw 'default|ug'
#lsconf|grep -i gateway
How to find out the MAC address of the network card in aix?
# netstat -ai
How to find out the netmask and other important details of the network card?
#lsdev -Cc adapter
#lsattr -El en0 (remember it is ent0, it is en0) (This will help when you are in a position to restore the network card when it crashed)
The above commands may be familiar to you. But I am sure, this will get you the exact/dir ..read more
IBM-AIX Blog
1y ago
Raid concept - How to deal with RAID concepts from an interview perspective?
RAID (Redundant Array of Independent Disks)
RAID 0 - RAID 1 - RAID 5 - RAID 10
RAID 0 (Striping)
==============
Not fault tolerance
Data is striped across multiple disks
The data will be lost if one of the disk got corruped/destroyed.
RAID 1 (Mirroring and Duplexing)
============================
Fault tolerant
Data is copied on more than one disk
Each disk has the same data (data is safe)
RAID 5 (Striping with parity)
======================
Requires 3 or more ..read more
IBM-AIX Blog
1y ago
How to view directories and sub-directories in aix?
Sometimes, you may in the situation to list out all the directories and sub-directories on the particular FS (or) directory in aix, Please use the below commands. It will list out all the directories and all the sub directories/files inside the directory/FS.
# ls -aeltFR ..read more
IBM-AIX Blog
1y ago
How to restore a directory from mksysb backup in aix?
Using the below command, we can restore the directory from the mksysb backup whenever you required.
For example, if you want to restore the directory - /var/spool/mail from the mksysb. Please follow below.
Check if the target directory is existing on the mksysb:
testlpar:# restore -T -q -l -f /backup/testlpar.mksysb |grep "/var/spool/mail"
It will list out the detailed output and at the end, it will display the directory which we need to recover.
drwxrwxr-x 2 bin mail 512 27 July 10:00 ./var/spool/mail ..read more
IBM-AIX Blog
1y ago
Facing issue while Restoring /image.data from mksysb image in aix?
Facing issue while Restoring /image.data from mksysb image in aix
testnim# alt_disk_mksysb -m testserver.mksysb -d hdisk3
Restoring /image.data from mksysb image.
checking disk sizes
0505-111 alt_disk_install: There is not enough disk space on target
disks specified.
Total disk space required is 67072 megabytes and target
disk space is only 34175 megabytes.
testnim#
(or)
testnim# alt_disk_mksysb -m testserver.mksysb -d hdisk3
Restoring /image.data from mksysb image.
checking disk sizes
creating cloned rootvg volume group a ..read more
IBM-AIX Blog
1y ago
What is NPIV in aix?
NPIV (N_Port ID Virtualization)
The virtual fiber channel adapters support the use of N-Port ID Virtualization (NPIV)
With NPIV, the VIO's role is fundamentally different, The VIOs serving NPIV is a pass through, providing a Fiber channel protocol (FCP) connection from the client to the SAN.
The Virutal Fiber channel adapter capability allows client partitions to access SAN (Storage Area Network) devices using NPIV. Each partition is identified by a unique WWPN.
Requirements:
============
Not all Fibre channel adapters and SAN Switches support NPIV.&nbs ..read more
IBM-AIX Blog
1y ago
How to enable the failed path in aix?
The below script (For Loop) will be used to Enabled the failed disk path in aix.
You no need to worry about the disk name/number and then fscsi/vscsi details. You can simply execute the below script and the script itself can able to fetch the failed disks and its fscsi/vscsi details on the server and then enabled it smoothly.
for s in `lspath|grep -i failed|awk '{print $2'}`
do
chpath -l $s -p `lspath -l $s|grep -i failed|awk '{print $3'}` -s Enabled
done
(or)
for s in `lspath|grep -i failed|awk '{print $2'}`; do chpath -l $s -p `lspath -l $s ..read more