Allison 3070 leaking
SteelSoldiers Forum
by brainsboy
37m ago
2001 M1078 with an Allison 3070. I had a real bad leak inside the bellhousing pretty much pouring out. Lost a gallon of fluid on the way home. I called Allison and got a new input shaft seal. Replaced the front input shaft seal, reinstalled the trans and still leaking the same didnt make any difference. Pulled the trans a second time and pulled off the cast iron center that the input seal presses into and found someone put it back on without a seal on the outside of it, thought great I... Allison 3070 leaking ..read more
Visit website
ECV/REV Aluminum Champion Radiator Fitment?
SteelSoldiers Forum
by EricSoWavy
2h ago
Since Champion has now released their taller aluminum radiator to fit ECV and REV models, has anyone installed it yet to confirm fitment? Any issues ..read more
Visit website
Cucv seat
SteelSoldiers Forum
by vascott
3h ago
Changed the seat out in my cucv. Would you guys keep the old one or what? Torn on whether to keep it or not ..read more
Visit website
Rear drive shaft question
SteelSoldiers Forum
by toxicroadkill
12h ago
I have a A0 M998 (1986), and the universal joints are coming up for replacement, just wondering, are there two variations of the drive shafts (I know that the cv axles have different ones), but do the driveshafts themselves have a heavier duty version also ..read more
Visit website
Spot mirror 5 ton etc-broken needed
SteelSoldiers Forum
by NDT
18h ago
Folks I have this mirror but the circled mount is rusted clean off. Need this part or a mirror that is broken that I can cannibalize the part from. TY ..read more
Visit website
New self canceling turn signal switch (stiff)
SteelSoldiers Forum
by Myrddin
18h ago
Hey folks. I just installed a new turn signal switch and it’s really stiff. It’s hard to cancel and requires manual reset. Is there any way to free it up ..read more
Visit website
M1152 A/C blowing hot
SteelSoldiers Forum
by Hmmv4me
18h ago
I have been working on this one for a while with little luck so figured I would jump in and post here. Pardon my ignorance, I am not great with A/C but I can usually get by. My M1152 front A/C unit blows warm to hot. No rear A/C installed. It will cool down a bit when I first start up but as soon as I take a drive, it's gone. Ambient temp today was 99. Low side is at 50psi, high side is at 315psi (at idle). Both fans on the condenser are running. compressor is running. I thought it was the... M1152 A/C blowing hot ..read more
Visit website
Anyone know where I can get these QR code/Bar labels/panels made?
SteelSoldiers Forum
by Gamble
21h ago
Looking to get a couple of these QR code panels made to place under the windshield of the truck to match the registered Vin number of the vehicle so Leo's wouldn't need to ask me to open my driver's door. Any ideas ..read more
Visit website
M35a2 Commercial Insurance
SteelSoldiers Forum
by Hummer Guy
21h ago
Has anyone ever gotten commercial insurance on their truck? From what I understand, it'll be pretty hard considering it doesn't have a 17 digit vin number ..read more
Visit website
1151a1 factory a/c right rear cond fans inop
SteelSoldiers Forum
by mrfarb
22h ago
Thought someone might be able to explain this - factory a/c front and rear. Just charging it, left rear cond fans run normal, right rear are not running - looked at wiring diagram and both are powered from the same relay. Has this happened before? Had to replace right rear fan assy, tested 437b and no power: Edit - I have .24 volts at each 437b and 437c, so I’m guessing the relay isn’t good, but still not sure how I get power to left rear cond fans and not right rear ..read more
Visit website

Follow SteelSoldiers Forum on FeedSpot

Continue with Google
Continue with Apple
OR